Как проверить на целое число в 1С 8 8.2 8.3?

Как проверить на целое число в 1С 8 8.2 8.3?

&НаСервере
Функция ПроверитьЧислоНаЦелое(ПроверяемоеЧисло)	
	  Возврат ПроверяемоеЧисло = Цел(ПроверяемоеЧисло);
КонецФункции

Для “Обычных форм”

Функция ПроверитьЧислоНаЦелое(ПроверяемоеЧисло)	
	  Возврат ПроверяемоеЧисло = Цел(ПроверяемоеЧисло);
КонецФункции

Применение функции на практике:

&НаКлиенте
Процедура ПроверкаЦеныНацелое();
	Для Каждого СтрокаТЧ Из Объект.ТЧ Цикл
		Если ПроверитьЧислоНаЦелое(СтрокаТЧ.Цена) <> Истина Тогда
			Сообщить("Обнаружена не точная цена: " + СтрокаТЧ.Номенклатура + " Цена: "+ СтрокаТЧ.Цена);
		КонецЕсли;
	КонецЦикла
КонецПроцедуры

&НаСервере
Функция ПроверитьЧислоНаЦелое(ПроверяемоеЧисло)	
	Возврат ПроверяемоеЧисло = Цел(ПроверяемоеЧисло);
КонецФункции   

&НаКлиенте
Процедура ПриОткрытии(Отказ)
	ПроверкаЦеныНацелое();
КонецПроцедуры

Пример того как работает функция проверки на целое число в 1С Предприятии:

Можете скачать *dt файл >>

Откройте документ “Поступление товаров и услуг”

Как проверить на целое число в 1С 8 8.2 8.3?

Затем откройте документ №2.

Как результат проверки числа на целое (на точную цену в табличной части документа) будет сообщение:

Как проверить на целое число в 1С 8 8.2 8.3?

Как проверить на целое число в 1С 8 8.2 8.3?

 

 

 



Есть вопросы? пишите в группу Telegram!

Сканируйте и присоединяйтесь к сообществу!

7 дней лекций – Бесплатно!

о том как правильно администрировать 1С