Как проверить на целое число в 1С 8 8.2 8.3?

Как проверить на целое число в 1С 8 8.2 8.3?

&НаСервере
Функция ПроверитьЧислоНаЦелое(ПроверяемоеЧисло)	
	  Возврат ПроверяемоеЧисло = Цел(ПроверяемоеЧисло);
КонецФункции

Для “Обычных форм”

Функция ПроверитьЧислоНаЦелое(ПроверяемоеЧисло)	
	  Возврат ПроверяемоеЧисло = Цел(ПроверяемоеЧисло);
КонецФункции

Применение функции на практике:

&НаКлиенте
Процедура ПроверкаЦеныНацелое();
 Для Каждого СтрокаТЧ Из Объект.ТЧ Цикл
 Если ПроверитьЧислоНаЦелое(СтрокаТЧ.Цена) <> Истина Тогда
 Сообщить("Обнаружена не точная цена: " + СтрокаТЧ.Номенклатура + " Цена: "+ СтрокаТЧ.Цена);
 КонецЕсли;
 КонецЦикла
КонецПроцедуры  &НаСервере
Функция ПроверитьЧислоНаЦелое(ПроверяемоеЧисло) 
 Возврат ПроверяемоеЧисло = Цел(ПроверяемоеЧисло);
КонецФункции
Продолжение статьи доступно только зарегистрированным пользователям!

Зарегистрироваться / Войти



Есть вопросы? пишите в группу Telegram!

Сканируйте и присоединяйтесь к сообществу!