Как в 1С округлить число в большую сторону ?

Функция округляет число в большую сторону:

&НаСервере
Функция ОкруглитьВбольшуюСторну(Сумма)	
	Возврат Сумма = Окр(Сумма+0.5,0,0);
КонецФункции   

Применение функции округления в большую сторону 1С Предприятие:

&НаКлиенте
Процедура ОкруглитьСумму();
	Для Каждого СтрокаТЧ Из Объект.ТЧ Цикл
		Если ОкруглитьВбольшуюСторну(СтрокаТЧ.Сумма) <> Истина Тогда
			Сумма = СтрокаТЧ.Сумма;
			Сообщить("Стоит округлить сумму: " + СтрокаТЧ.Номенклатура + " Рекомендация: " + Окр(Сумма+0.5,0,0));
		КонецЕсли;
	КонецЦикла
КонецПроцедуры

// Пример функции округлить (Пример №1)
// Например число 7.1 к 8 (Целому в большую сторону)
&НаСервере
Функция ОкруглитьВбольшуюСторну(Сумма)	
	Возврат Сумма = Окр(Сумма+0.5,0,0);
КонецФункции   

&НаКлиенте
Процедура ПриОткрытии(Отказ)
	ОкруглитьСумму();
КонецПроцедуры




//Для округления чисел в 1С используем функцию 1С - Окр(12.55)
//1С вернет 12
//С помощью 1С ОКР можно проводить округление дробной части чисел 1С (все то, что идет после запятой), например до сотых двух знаков):
//РезультатФункции = Окр(15.2233, 2); //15.22

//С помощью 1С ОКР можно проводить округление целой части чисел 1С (то, что идет до запятой), например до тысяч (трех знаков):
//РезультатФункции = Окр(12333, -3); //12000

Пример того как работает функция округления в большую сторону смотрите пример в *dt

Скачать тут >>

Открываем второй документ “ПоступлениеТоваровИУслуг” и тут же сработает условие (проверка, нуждается ли сумма в округлении). И если да, тогда Вы получите сообщение какой товар (сумму) нужно округлить.

Как в 1С округлить число в большую сторону ?

 

Для округления чисел в 1С используем функцию 1С – Окр(12.55)

1С вернет 12

С помощью 1С ОКР можно проводить округление дробной части чисел 1С (все то, что идет после запятой), например до сотых двух знаков):

РезультатФункции = Окр(15.2233, 2);

15.22

С помощью 1С ОКР можно проводить округление целой части числа 1С (то, что идет до запятой), например до тысяч (три знака):

РезультатФункции = Окр(12333, -3); //12000

 

 



Есть вопросы? пишите в группу Telegram!

Сканируйте и присоединяйтесь к сообществу!

Уроки Бесплатно!

Узнайте как правильно администрировать 1С