Программирование в 1С Архивы

Отзывы участников тренинга 1С 8.3 Старт

Здравствуйте, прошел курс. Очень подробно описаны все компоненты, приведены примеры их работы. Интересные домашние задания, есть моменты где нужно подумать самому. Рекомендую данный курс всем начинающим программистам 1С. Читать далее

Топ 5 обработок для 1С Предприятия

Публикую в бесплатном доступе ТОП 5 обработок, которые чаще всего использую на практике. Обработки позволяют: Быстро в групповом порядке переименовать любые документы и справочники в 1С Предприятии. Распровести, Читать далее

Как в 1С округлить число в большую сторону ?

Функция округляет число в большую сторону: &НаСервере Функция ОкруглитьВбольшуюСторну(Сумма) Возврат Сумма = Окр(Сумма+0.5,0,0); КонецФункции Применение функции округления в большую сторону 1С Предприятие: &НаКлиенте Процедура ОкруглитьСумму(); Для Каждого СтрокаТЧ Читать далее

Как проверить на целое число в 1С 8 8.2 8.3?

Как проверить на целое число в 1С 8 8.2 8.3? &НаСервере Функция ПроверитьЧислоНаЦелое(ПроверяемоеЧисло) Возврат ПроверяемоеЧисло = Цел(ПроверяемоеЧисло); КонецФункции Для “Обычных форм” Функция ПроверитьЧислоНаЦелое(ПроверяемоеЧисло) Возврат ПроверяемоеЧисло = Цел(ПроверяемоеЧисло); КонецФункции Читать далее

Как проверить на четное число в 1С 8 8.2 8.3?

Как проверить на четное число в 1С 8 8.2 8.3? &НаСервере Функция ПроверитьЧетноеЧисло(ПроверяемоеЧисло) Число = ПроверяемоеЧисло%2=0; Возврат Число; КонецФункции Ниже пример использования функции на четное число. &НаКлиенте Процедура Читать далее

Универсальная обработка для смены нумерации, перенумерации справочников в 1С Предприятии

Данная универсальная обработка предназначена для групповой перенумерации справочников в 1С Предприятии. (8, 8.1, 8.2 и 8.3) (Управляемые и обычные формы). Работать с обработкой очень просто: Сперва запустим 1С Читать далее

«Обязан» ли администратор 1С разбираться в программировании 1С ?

Мое мнение – Нет! Но если Вы спросите: «Пойдет ли навык программиста 1С (пускай даже начальный), администратору на пользу?» ответ однозначно – Да! Представьте ситуацию, когда в штате Читать далее