Программируем в 1С Архивы

Как в 1С округлить число в большую сторону ?

Функция округляет число в большую сторону: &НаСервере Функция ОкруглитьВбольшуюСторну(Сумма) Возврат Сумма = Окр(Сумма+0.5,0,0); КонецФункции Применение функции округления в большую сторону 1С Предприятие: &НаКлиенте Процедура ОкруглитьСумму(); Для Каждого СтрокаТЧ Читать далее

Как проверить на целое число в 1С 8 8.2 8.3?

Как проверить на целое число в 1С 8 8.2 8.3? &НаСервере Функция ПроверитьЧислоНаЦелое(ПроверяемоеЧисло) Возврат ПроверяемоеЧисло = Цел(ПроверяемоеЧисло); КонецФункции Для “Обычных форм” Функция ПроверитьЧислоНаЦелое(ПроверяемоеЧисло) Возврат ПроверяемоеЧисло = Цел(ПроверяемоеЧисло); КонецФункции Читать далее

Как проверить на четное число в 1С 8 8.2 8.3?

Как проверить на четное число в 1С 8 8.2 8.3? &НаСервере Функция ПроверитьЧетноеЧисло(ПроверяемоеЧисло) Число = ПроверяемоеЧисло%2=0; Возврат Число; КонецФункции Ниже пример использования функции на четное число. &НаКлиенте Процедура Читать далее

Как включить отладку в клиент-сервере (Кластер серверов 1С )

Известно, что в клиент-серверном варианте работы в 1С, по умолчанию не работает отладка. Она конечно, работает, да вот только на клиенте, и абсолютно не работает на сервере. То Читать далее

Как очистить регистр расчета в 1С 8.2 – 8.3

Как очистить регистр расчета в 1С 8.2 – 8.3 Запрос=Новый Запрос; Запрос.Текст = "ВЫБРАТЬ РАЗЛИЧНЫЕ | УправленческиеНачисления.Регистратор |ИЗ | РегистрРасчета.УправленческиеНачисления КАК УправленческиеНачисления"; РезультатЗапроса = Запрос.Выполнить(); Выборка = РезультатЗапроса.Выбрать(); Читать далее

Как просто записать в Регистр Накопления 1С 8.2 – 8.3

Простая запись в Регистр Накопления 1С 8  Для Каждого ТекСтрокаТЧ Из ТЧ Цикл                     Движение = Движения.РегистрНакопЗак.ДобавитьПриход();         Движение.Период = Дата;         Читать далее

Как очистить значения всех констант в 1С 8.2 – 8.3

Как очистить значения всех констант в 1С 8.2 – 8.3: Для Каждого ОчереднаяКонстанта Из Константы Цикл КонецЦикла;   Если Вы хотите больше узнать о программировании в 1С, тогда Читать далее

Как искать документ по реквизиту в 1С 8.2 – 8.3

Поиск документа по реквизиту 1С 8 //   Место = "Фабрика"; Документы.ПоступлениеТоваров.НайтиПоРеквизиту("МестоХранения", Место); Если Вы хотите больше узнать о программировании в 1С, тогда регистрируйтесь на курс: 1С 8.3 Старт >>>   Читать далее