Как проверить на четное число в 1С 8 8.2 8.3?

Как проверить на четное число в 1С 8 8.2 8.3?

&НаСервере
Функция ПроверитьЧетноеЧисло(ПроверяемоеЧисло)
	Число = ПроверяемоеЧисло%2=0;
	Возврат Число;
КонецФункции

Ниже пример использования функции на четное число.

&НаКлиенте
Процедура СтрокиПроверитьНаЧет();
	Для Каждого СтрокаТЧ Из Объект.ТЧ Цикл
		//	 ПроверитьЧетноеЧисло(СтрокаТЧ.НомерСтроки);		
		//Сообщить(ПроверитьЧетноеЧисло(СтрокаТЧ.НомерСтроки)); 
		Если ПроверитьЧетноеЧисло(СтрокаТЧ.НомерСтроки) = Истина Тогда
			Сообщить("Четное :" + СтрокаТЧ.НомерСтроки);
		КонецЕсли;
	КонецЦикла
КонецПроцедуры

// Сама функция проверки на четное число, остальное лишь пример использования
&НаСервере
Функция ПроверитьЧетноеЧисло(ПроверяемоеЧисло)
	Число = ПроверяемоеЧисло%2=0;
	Возврат Число;
КонецФункции

&НаКлиенте
Процедура ПриОткрытии(Отказ)
	СтрокиПроверитьНаЧет();
КонецПроцедуры

Пример того как можно применить данную функцию изложен в *dt файле, можете скачать бесплатно ниже по ссылке.

Скачать пример (*dt) проверки на четное нечетное число >>

При открытии любого документа “Поступление товаров и услуг” сработает функция и проверит на четное не четное табличную часть документа его строки.

Согласно условию, если строка по номеру четная, выведет сообщение “Четная + номер строки”.

Как проверить на четное число в 1С 8 8.2 8.3?

Как проверить на четное число в 1С 8 8.2 8.3?

 

 

 



Есть вопросы? пишите в группу Telegram!

Сканируйте и присоединяйтесь к сообществу!

Уроки Бесплатно!

Узнайте как правильно администрировать 1С