Как проверить на четное число в 1С 8 8.2 8.3?

Как проверить на четное число в 1С 8 8.2 8.3?

&НаСервере
Функция ПроверитьЧетноеЧисло(ПроверяемоеЧисло)
	Число = ПроверяемоеЧисло%2=0;
	Возврат Число;
КонецФункции

Ниже пример использования функции на четное число.

&НаКлиенте
Процедура СтрокиПроверитьНаЧет();
 Для Каждого СтрокаТЧ Из Объект.ТЧ Цикл
 //	 ПроверитьЧетноеЧисло(СтрокаТЧ.НомерСтроки); 
 //Сообщить(ПроверитьЧетноеЧисло(СтрокаТЧ.НомерСтроки)); 
 Если ПроверитьЧетноеЧисло(СтрокаТЧ.НомерСтроки) = Истина Тогда
 Сообщить("Четное :" + СтрокаТЧ.НомерСтроки);
 КонецЕсли;
 КонецЦикла
КонецПроцедуры  // Сама функция проверки на четное число, остальное лишь пример использования
&НаСервере
Функция ПроверитьЧетноеЧисло(ПроверяемоеЧисло)
 Число = ПроверяемоеЧисло%2=0;
 Возврат Число;
КонецФункции
Продолжение статьи доступно только зарегистрированным пользователям!

Зарегистрироваться / Войти

 



Есть вопросы? пишите в группу Telegram!

Сканируйте и присоединяйтесь к сообществу!