Как вывести на печать таблицу значений в 1С 8.2 – 8.3

Процедура ТЗПечать(ТЗ,Заголовок="") Экспорт
 Перем Таб, Кол,Стр;
#Если Клиент Тогда
 Линия = Новый Линия(ТипЛинииЯчейкиТабличногоДокумента.Сплошная,1);
 ТолстаяЛиния = Новый Линия(ТипЛинииЯчейкиТабличногоДокумента.Сплошная, 2);
 Таб=Новый ТабличныйДокумент;
 Таб.Область(1,1).Текст=Заголовок;
 Таб.Область(1,1).ШиринаКолонки = 4;
 Таб.Область(1,1).Обвести(ТолстаяЛиния,ТолстаяЛиния,ТолстаяЛиния,ТолстаяЛиния);
 Для Кол=1 По ТЗ.Колонки.Количество() Цикл
 врЗаголовок = "";
 Если СокрЛП(Строка(ТЗ.Колонки[Кол-1].Заголовок)) <> "" Тогда
 врЗаголовок = Строка(ТЗ.Колонки[Кол-1].Заголовок);
 Иначе
 врЗаголовок = Строка(ТЗ.Колонки[Кол-1].Имя)
 КонецЕсли;
 Таб.Область(2,Кол+1).Текст = врЗаголовок;
 Таб.Область(2,Кол+1).Шрифт = Новый Шрифт(,,Истина);// жирный
 Таб.Область(2,Кол+1).Обвести(ТолстаяЛиния,ТолстаяЛиния,ТолстаяЛиния,ТолстаяЛиния);
 врШир = ТЗ.Колонки[Кол-1].Ширина;
 Если врШир > 0 Тогда
 Таб.Область(2,Кол+1).ШиринаКолонки = врШир;
 КонецЕсли;
 КонецЦикла;
 i=0;
Продолжение статьи доступно только зарегистрированным пользователям!

Зарегистрироваться / Войти

 

 

Если Вы хотите больше узнать о программировании в 1С, тогда регистрируйтесь на курс: 1С 8.3 Старт >>>



Есть вопросы? пишите в группу Telegram!

Сканируйте и присоединяйтесь к сообществу!