Как сделать простой подсчет Суммы в ТЧ документа в 1С

Как сделать простой подсчет Суммы в Табличной части документа на управляемых формах.

В 1С Предприятии 8.2 -8.3.

// Общий модуль

Процедура РассчетатьСумму(СТЧ)Экспорт
  СТЧ.Сумма = СТЧ.Количество * СТЧ.Цена;
КонецПроцедуры

&НаКлиенте
Процедура МатериалыКоличествоПриИзменении(Элемент)
    СТЧ = Элементы.Материалы.ТекущиеДанные;
    РаботаСДокументами.РассчетатьСумму(СТЧ);
КонецПроцедуры

&НаКлиенте
Процедура МатериалыЦенаПриИзменении(Элемент)
    МатериалыКоличествоПриИзменении(Элемент);       // НЕ ДУБЛИРУЕМ ПРОЦЕДУРУ ВВЕРХУ ! 
КонецПроцедуры


// стч - Табличная часть

 



Есть вопросы? пишите в группу Telegram!

Сканируйте и присоединяйтесь к сообществу!

Уроки Бесплатно!

Узнайте как правильно администрировать 1С