Как очистить регистр расчета в 1С 8.2 – 8.3

Как очистить регистр расчета в 1С 8.2 – 8.3


Запрос=Новый Запрос;
 Запрос.Текст = "ВЫБРАТЬ РАЗЛИЧНЫЕ
 | УправленческиеНачисления.Регистратор
 |ИЗ
 | РегистрРасчета.УправленческиеНачисления КАК УправленческиеНачисления";
 РезультатЗапроса = Запрос.Выполнить();
 Выборка = РезультатЗапроса.Выбрать();
 Кол=0;
 БылиОшибки=Ложь;
 
 //РегистрыНакопления.ЗаказыМагазинов.УстановитьИспользованиеИтогов(Ложь);
 
 Пока Выборка.Следующий() цикл
 //ОбработкаПрерыванийПользователя();
 
 Набор = РегистрыРасчета.УправленческиеНачисления.СоздатьНаборЗаписей();
 Набор.Отбор.Регистратор.Значение = Выборка.Регистратор;
 Попытка
 Набор.Записать();
 Исключение
 БылиОшибки=Истина;
 КонецПопытки;
 Кол=Кол+1;
 ЕСЛИ Кол%100=0 Тогда
 Сообщить("Отработано "+Кол+" документов из "+Выборка.Количество());
 КонецЕсли;
 КонецЦикла;
 //РегистрыНакопления.ЗаказыМагазинов.УстановитьИспользованиеИтогов(Истина);
 
 
 Если БылиОшибки Тогда
 Предупреждение("Обработка завершена. Регистр очищен не до конца!!!");
 КонецЕсли;

 



Есть вопросы? пишите в группу Telegram!

Сканируйте и присоединяйтесь к сообществу!

 

Программа помощник Администратора 1С

Скачай бесплатно YaAdmin !
Программа YaAdmin помощник администратора 1С

Уроки Бесплатно!

Узнайте как правильно администрировать 1С